Issues with the Danish support phone line

Incident Report for Talentech

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 13:13 CEST

Investigating

We are currently experiencing issues with the Danish support telefone and it is not possible to contact us via phone.
Please send a ticket via https://customerportal.talentech.com/da/knowledge/kb-tickets/new
Posted Sep 18, 2025 - 11:50 CEST
This incident affected: irecommend, Ontame, People Core, Talent Manager, Talent Recruiter, Talentech ID, Talmundo, ReachMee, and Weekli.