Delays in mails from the system

Incident Report for Talentech

Resolved

This incident has been resolved.
Posted Mar 08, 2026 - 10:08 CET

Monitoring

We have made a fix and are now monitoring the service
Posted Mar 06, 2026 - 12:03 CET

Identified

We have identified the root cause of delayed email and are now implmenting a fix to this.
Posted Mar 06, 2026 - 09:42 CET

Investigating

We are having problems with mails not being sent from the system and are working on identifying the root cause of this.
Posted Mar 06, 2026 - 00:26 CET
This incident affected: Talent Manager and Talent Recruiter.