Issues with menu system

Incident Report for Talentech

Resolved

This incident has been resolved
Posted Oct 24, 2025 - 13:05 CEST

Monitoring

A fix has been implemented and we are now monitoring the service.
Posted Oct 24, 2025 - 10:09 CEST

Investigating

We have issues with a central api for the Talentech menu which gives a degraded performance for some of our products. We are investigating the issue, and will come back soon with information when we have identified the problem.
Posted Oct 24, 2025 - 09:57 CEST
This incident affected: People Core, Talent Recruiter, Talentech ID, ReachMee, and Webcruiter.